Rancilio S27 - Restoration? - Page 5

Equipment doesn't work? Troubleshooting? If you're handy, members can help.
jgrosjean (original poster)

#41: Post by jgrosjean (original poster) »

Another question... anyone had luck setting the dose volumes?

In a user guide that I have it says:



But I'm not sure that I can even get through step (1). I press and hold and after 8-10 seconds the water does stop flowing... but the continuous doser light does not start flashing. And none of the other steps then seem to do anything. I'm not sure that I'm entering program mode.

napierzaza

#42: Post by napierzaza »

I used to have an s27, and the only thing that didn't work on it was the volumetrics. I went through the setup, and the volume seemed to be perfectly correct to what I set. But when I ran it with coffee in the portafilter it would just stop right away somehow. I thought maybe the sensor was broken but I never got around to figuring it out. I just used the infinite option.

Coffcarl

#43: Post by Coffcarl »

Try holding the button down longer? In the downloaded manual, it is button "E", which the diagram shows as the rightmost button on your panel.

Luckily, you have a second machine, so if you cannot get it to work, I would swap in the control board from the other machine.

jgrosjean (original poster)

#44: Post by jgrosjean (original poster) »

napierzaza wrote:I used to have an s27, and the only thing that didn't work on it was the volumetrics. I went through the setup, and the volume seemed to be perfectly correct to what I set. But when I ran it with coffee in the portafilter it would just stop right away somehow. I thought maybe the sensor was broken but I never got around to figuring it out. I just used the infinite option.
I just figured this out when trying to fix another problem.

In the upper right corner of the logic board there is a "programming lockout switch". On my machine it wasn't connected, when I connected it then I could enter programming mode.