Profitec Pro 700 Leak

Equipment doesn't work? Troubleshooting? If you're handy, members can help.
Snoroqc

#1: Post by Snoroqc »

I have a leak under the profitec pro 700. The T is desintegrated. May be IDC can send me the part, May i find it elsewhere ?


Auctor

#2: Post by Auctor »

If you don't mind me asking, does the component that disintegrated connect to the steam boiler? If so, at what temp you keep your steam boiler?

Decent Espresso: espresso equipment for serious baristas
Sponsored by Decent Espresso
User avatar
GC1

#3: Post by GC1 »

Same thing occurred with with my Profitec Pro 700-it's a common point of failure.
WLL sent a new Tee Connector and 8mm silicone tubing. About $15 all together.

Snoroqc (original poster)

#4: Post by Snoroqc (original poster) »

Yes it connect to steam boiler. The temp is set to 253 wich is within recommandations.

Snoroqc (original poster)

#5: Post by Snoroqc (original poster) »

I found a t at the car department at a Canadian Tire. Lucky me. Profitec up and running.

physh

#6: Post by physh »

I'd be concerned about lead or other contaminants.

Snoroqc (original poster)

#7: Post by Snoroqc (original poster) »

Nope. One way out to the discharge nozzle. Then to the drip tray.

CafelatStore: home of Cafelat products online
Sponsored by CafelatStore
kitt

#8: Post by kitt »

It usually disintegrates due to heat when the antivac valve fails, best to change that also, otherwise your just fixing the symptom ,not the cause

Snoroqc (original poster)

#9: Post by Snoroqc (original poster) » replying to kitt »

Yes thank for pointing that. The brew boiler is leaking too at the refill elbow. Times for an overhaul.

Snoroqc (original poster)

#10: Post by Snoroqc (original poster) »

The machine is leaking from temp probe and Elbow (red zone).

According to the parts diagram, the seal is made with copper seal for the elbow.
I have Loctite 567 High Temperature Thread Sealant

Any recommandation ?