Nuova Simonelli Musica, in need of EEPROM

Equipment doesn't work? Troubleshooting? If you're handy, members can help.
mikkele86

#1: Post by mikkele86 »

Hello. new to this forum.
hopefully someone can help me :)

I have a Simonelli Musica which does not respond to eny buttons nor lights up.

I did probe around with a multimeter and could confirm the IC is supplied with all the correct voltages.
next i did a backup of the EEPROM data, replaced the chip and reprogrammed the nenw IC, but nothing happends. voltage the same.

My PCB is a
CUBIC RICERCA
OSCAR1v220V
04900788

I use a, xgecu pro TL866-2 plus, to read and write data through det MOSI/MISO pins on the ATMEL ATmega48 IC.

User avatar
BaristaBoy E61

#2: Post by BaristaBoy E61 »

Welcome to HB Mikkel!

Can you post a complete, detailed electronic schematic of your machine?

Generally devices such as the EEPROM are quite reliable. The problem is probably elsewhere. I would suggest starting with fuses and resettable breakers, thermal and current. Check all the supply voltages. Look for evidence of electrical connectors and wires that are discoloured by heat.
"You didn't buy an Espresso Machine - You bought a Chemistry Set!"

mikkele86 (original poster)

#3: Post by mikkele86 (original poster) »

Hello.

I'm making my own schematic but its not 100% done yet.

i got the following measurements.
+16v on input on both voltage regulators.
+5v out on LM78M05
+12v out on LM7812

On the ATMEL ATmega48 i got

pin 1, 0v
pin 4,6,18(Vcc) i got +5v
pin 7, +4,5v
pin 8, +4,5v
pin 29(RESET#), +5v


User avatar
BaristaBoy E61

#4: Post by BaristaBoy E61 »

You can check the discreet components (resistors, diodes, and capacitors) with your Fluke to see why there is no voltage on any of pins 1 & 4 of the relay coils.
"You didn't buy an Espresso Machine - You bought a Chemistry Set!"