No water nor pressure on Breville BES860XL

Equipment doesn't work? Troubleshooting? If you're handy, members can help.
Rama Bali
Posts: 1
Joined: February 12th, 2018

Postby Rama Bali » Feb 12, 2018, 9:49 pm

Hi I had Breville BES860XL for about 4 years now. I just changed its solenoid valve assembly about 2 months ago because its seems the pressure getting lower/inconsistent and did cleaning-decalcifying use vinegar-water 30-60 and after that was working back normally. After about 3 month, the espresso getting less and less pressure at its shower head (back to inconsistent again) and I decided to changed its pump (all new and original parts). Its getting worst after that. The pump has a normal noise indicate its working but after 2-3 seconds the noise become very weak and no water came out from its head and no pressure at its gauge at all. Steam wand working perfectly. I re-open again to see and put colour water in the tray (make it easier to detect) and saw that a water in the pipe from solenoid valve assembly that goes to shower head and pressure gauge cannot goes up (only half way) into its channel. Is this means a blockage in its solenoid valve assembly again? I try to contact Breville technical support but no luck. Please help.

nicholasnumbers
Posts: 71
Joined: March 26th, 2015

Postby nicholasnumbers » Feb 13, 2018, 12:25 pm

Did you test the pump independently before you installed it?

I've had repairs where a "new" pump was defective. I'd pull the pump out and see if it's truly pumping water.

Nick

User avatar
slipchuck
Posts: 574
Joined: April 12th, 2017

Postby slipchuck » Feb 13, 2018, 5:12 pm

Did you check the in line filter? Also, these models have been known to get clogged hoses

Good luck

Randy
The only bad decisions are the decisions you didn't make

 
Sponsored by counterculturecoffee.com
www.counterculturecoffee.com: coffee driven people, people driven coffee