Help with La Pavoni Domus Bar electrical problem - Page 3

Equipment doesn't work? Troubleshooting? If you're handy, members can help.
Seafoamgreen (original poster)

#21: Post by Seafoamgreen (original poster) »

Javierba wrote: With that said, you can find the olab three way valves very cheap in aliexpress
Ordered and replaced the three way valve. No leakinh through the group head now, but instead it leaks out the drain. Still leakage though. It doest stop until I turn off steam. So all steam leaking out.

Seafoamgreen (original poster)

#22: Post by Seafoamgreen (original poster) »

Should the three way valve close when turning steam on? When I turn the pump on I get 230V going to the valve, but 0V when turning on steam.

Cerini Coffee & Gifts: official US importer for Olympia Express
Sponsored by Cerini Coffee & Gifts
Javierba

#23: Post by Javierba »

The three way walve should only be powered (connecting the boiler and the brew head) when the pump is turned on, otherwise has to be powered off (connecting the brew head to the drain)

Seafoamgreen (original poster)

#24: Post by Seafoamgreen (original poster) » replying to Javierba »

Thanks! With the new three way valve the steam leaks to the drain instead of the group head as it did before. But should not leak at all, it should stay in and only getting out when opening the steam wand. Any idea what part to look at?

http://nibra.altervista.org/wp-content/ ... re2007.jpg

JRising

#25: Post by JRising »

I'm not sure what you're saying. The steam wand and the brew circuit's 3 way valve are not connected.

If you're saying that the pressure is escaping the boiler through the three-way valve's drain with the valve NOT energized (not brewing), do you maybe have the three-way valve in backward? Ie, It's got the port that should be connected to brew-head connected to boiler and vice versa?

Seafoamgreen (original poster)

#26: Post by Seafoamgreen (original poster) » replying to JRising »

Brewing coffee works fine. But cant build up steam for the stream wand as it keeps leaking out the drain.
This is how it looks like now.


RobAnybody

#27: Post by RobAnybody »


looking at the picture you sent, this looks like a 2-way solenoid with a T connection screwed in.

anyways
do you maybe have the three-way valve in backward? Ie, It's got the port that should be connected to brew-head connected to boiler and vice versa?
As JRising mentioned if you have the valve the wrong way around the steam pressure will force the valve open and you will have it leaking to the drain.

cheers,
Rob
LMWDP #647

La Marzocco · Home: customized for espresso aficionados
Sponsored by La Marzocco · Home
Seafoamgreen (original poster)

#28: Post by Seafoamgreen (original poster) »

RobAnybody wrote:image
As JRising mentioned if you have the valve the wrong way around the steam pressure will force the valve open and you will have it leaking to the drain.
Of course! Thats it! I put it in the wrong way, fixed it and now I think I'm done!

Thanks everyone for helping out! I've learned a lot about this machine, thanks to you guys. Looks like everything's working properly now. Hope it continues that way! All the best!