Repairs, Restorations & Mods

Equipment doesn't work? Troubleshooting? If you're handy, members can help.
  • Announcements
    Replies
    Views
    Last post
  • Read before posting
    by HB »
    0 Replies
    5152 Views

    Last post by HB
  • Topics
    Replies
    Views
    Last post
  • ECM Synchronika pump ramp up noise normal?
    by Mggray87 »
    4 Replies
    36 Views

    Last post by Nunas
  • Profitec Pro 700 - Losing temperature, not heating back up
    by MrBaggins »
    14 Replies
    115 Views

    Last post by MrBaggins
  • Rocket Appartamento shuts off after two minutes
    by lorinc »
    4 Replies
    56 Views

    Last post by lorinc
  • Portafilter went from chrome to matte how to restore?
    by Kaka »
    3 Replies
    74 Views

    Last post by Kaka
  • Remove inner plastic from portafilter?
    by Wantboost »
    4 Replies
    103 Views

    Last post by tran63841
  • Replacing La Marzocco GS3 vacuum breaker
    by DaumierS »
    11 Replies
    109 Views

    Last post by Peppersass
  • Bezzera BZ07 sometimes heats up and builds steam pressure, sometimes not
    by YvesMcQueen »
    1 Replies
    30 Views

    Last post by JRising
  • Buzzing solenoid
    by Michalstojan »
    1 Replies
    37 Views

    Last post by JRising
  • Rocket Appartamento not heating
    by musica »
    36 Replies
    353 Views

    Last post by musica
  • Rocket R58 idle temperature + gushing like crazy!
    by AndersHP »
    7 Replies
    161 Views

    Last post by JRising