Repairs, Restorations & Mods

Equipment doesn't work? Troubleshooting? If you're handy, members can help.
  • Announcements
    Replies
    Views
    Last post
  • Read before posting
    by HB »
    0 Replies
    5385 Views

    Last post by HB
  • Topics
    Replies
    Views
    Last post
  • OPV not working correctly??
    by BaristaMcBob »
    11 Replies
    104 Views

    Last post by JRising
  • Nuova Simonelli Oscar II produces steam pressure but cold water at grouphead
    by Marthvader »
    6 Replies
    84 Views

    Last post by jfuents
  • Profitec Pro 800 Needs Some Diagnosis and Repairs
    by Pushjerk »
    10 Replies
    252 Views

    Last post by GregoryJ
  • Help with Quickmill QM-67 auto shutoff problem
    by slyfink »
    2 Replies
    43 Views

    Last post by slyfink
  • Expobar Control water flow issue
    by Espresso-norm »
    0 Replies
    16 Views

    Last post by Espresso-norm
  • Profitec Pro 500 brew pressure dropping
    by nlaul1 »
    2 Replies
    26 Views

    Last post by nlaul1
  • La Marzocco Linea Mini intermittent boiler refill fails
    by BAEvans »
    1 Replies
    77 Views

    Last post by Jake_G
  • Rancilio Silvia - Pump Works Continuously & Brew Shorting
    by randew »
    2 Replies
    68 Views

    Last post by randew
  • Lelit PL41PLUST (AUS) with PID - aka Glenda - Pump only functions when machine cold
    by mshannon »
    12 Replies
    165 Views

    Last post by patcof1
  • Compression Sleeves
    by wolfpv »
    2 Replies
    109 Views

    Last post by wolfpv