Site upgrade

Offer your ideas on how to improve the site or report problems.
User avatar
HB
Admin

#1: Post by HB »

It's time for the site's annual disaster recovery test; that's where I rebuild the site from scratch based on backups and confirm the procedure works as expected. The only upgrade will be in boring techie stuff like the database version and whatnot -- nothing operationally as the user level will change. It's my hope, however unlikely, that this refresh will fix the ongoing Cloudflare 520 errors. :D

The site will be read-only tomorrow for an hour or so while I copy over the latest content from the "old" site onto the "new" one.
Dan Kehn

User avatar
HB (original poster)
Admin

#2: Post by HB (original poster) »

The upgrade is complete. Please let me know about any unexpected behavior; if you see Cloudflare 520 errors, please reply to this thread.

UPDATED to add - Here's how to collect relevant data from Troubleshooting Cloudflare 5XX errors, with modifications:
If 520 errors continue after contacting your hosting provider or site administrator, provide the following information to Cloudflare Support:
  • Full URL(s) of the resource requested when the error occurred
  • Cloudflare cf-ray from the 520 error message
  • Output from /cdn-cgi/trace
  • Two HAR files: one with Cloudflare enabled on your website, and the other with Cloudflare temporarily disabled.
The last one about HAR files is extra credit; it captures what's shown in the browser.
Dan Kehn

Weber Workshops: tools for building better coffee
Sponsored by Weber Workshops
User avatar
Brewzologist
Supporter ♡

#3: Post by Brewzologist »

Thanks for all you do to keep HB running smoothly. It's a great resource for me. Much appreciated.

Steve

User avatar
HB (original poster)
Admin

#4: Post by HB (original poster) »

I applied a small upgrade (phpBB 3.3.4 to 3.3.5); everything seems OK... except youtube/vimeo embeds are no longer working. :| I'll look into it. In the meantime, if you see any other unexpected behaviors, please let me know.
Dan Kehn

mwynne

#5: Post by mwynne »

Just want to say that I haven't got a single 5xx error in the last several weeks!
LMWDP #673