Generic 520 errors

Offer your ideas on how to improve the site or report problems.
mwynne

#1: Post by mwynne »

Not quite sure where to post this, but I've been getting 520 server errors on an off all day (something I've never come across here yet). I think I saw an announcement about some server updates within the last few days - not sure if this is related or not, and it's not a huge issue for me, but thought it may be useful to report.

Also happy to send any details/diagnostics from my end if that's of use.

User avatar
HB
Admin

#2: Post by HB »

Hmm-m. I changed servers over the weekend and the performance seems good most of the time. While I haven't seen any Cloudflare 520 errors, I have noticed occasional hiccups where a page will take 2-3 seconds instead of a more zippy half second. I'll look into the logs and try some performance tuning.
Dan Kehn

mwynne

#3: Post by mwynne »

Whoops, I didn't scroll down far enough past the pinned posts!

Again, not a major issue at all, just reporting since feedback was requested.

Thanks so much Dan

User avatar
HB
Admin

#4: Post by HB »

No worries! The new servers are the most recent Linux/database versions; that's good from a support and security viewpoint, but it usually means that version-specific performance tuning will be required. I've already applied some tweaks that hopefully will reduce/eliminate the timeouts you saw.
Dan Kehn

User avatar
HB
Admin

#5: Post by HB »

I've tuned the servers a bit and now they seem pretty zippy. :D Let me know if you continue to see Cloudflare errors.
Dan Kehn