Embedded YouTube videos are inverted

Offer your ideas on how to improve the site or report problems.
one_good_coffee

#1: Post by one_good_coffee »

I don't know if it's only on my side, but there is a huge brightness issue on my side on the video.

The thumbnail looks ok, but as soon as you start the video it's almost completely white.

Jonk

#2: Post by Jonk »

Been that way for a while now for me as well, embedded youtube videos become inverted on H-B for some reason. I just search for the videos directly in youtube instead.

User avatar
HB
Admin

#3: Post by HB »

What browser and platform? It displays correctly for me with several browsers on my laptop. If you're using "dark mode", an inverse is applied to the page, but there should be an inverse-of-inverse applied to videos.
Dan Kehn

User avatar
Jake_G
Team HB

#4: Post by Jake_G »

Turning off dark mode fixes it.

But my eyes hurt!

Dan, the embedded video is just fine, but the inverted inversion fails when you expand to full screen. This is on a Samsung mobile device running chrome, for reference.

Cheers!

- Jake

mwynne

#5: Post by mwynne »

Just chiming in for data.

MacBook Pro, MacOS Catalina, Firefox.

Running system-wide dark mode (applies to browser) and HB dark mode.

Video is fine inline, but does colour invert at fullscreen.

User avatar
Jake_G
Team HB

#6: Post by Jake_G »

Does it fix if you run HB in "normal" mode?

User avatar
HB
Admin

#7: Post by HB »

Ah, I see the problem when (a) in dark mode, and (b) the video is maximized. I've added some code to hopefully correct it.
Dan Kehn

mwynne

#8: Post by mwynne »

Now working as expected for my set up mentioned above!

Jonk

#9: Post by Jonk »

Using Chrome in dark mode on an Android phone, works correctly now in fullscreen. But checked on a laptop before my last post, still inverted on Chrome/Windows not running dark mode - whether maximized or not. No issue with Firefox or Edge.

User avatar
Jake_G
Team HB

#10: Post by Jake_G »

All better on this end.

Thanks Dan!