Daily login required again... - Page 3

Offer your ideas on how to improve the site or report problems.
User avatar
HB
Admin

#21: Post by HB »

I was able to reproduce the random logouts on Safari; it appears to be related to the "Remember me" option on login. It was checked by default, but as a test, I've switched it to unchecked. This works around the problem of random session drops. Of course, that means regulars will need to login more frequently, but if you're willing to let your browser remember the password, it's not too annoying.

While I was there, I added some code to tidy up cookies and remove your associated "remember me" keys from the database; just click forget me. You'll be logged out (sorry), but presumably the next login will be more stable (and if not, easier to debug). The link is also at the bottom of the index for easy reference, look for "To delete cookies associated with this site, click here".

Let me know if the above (not checking "remember me", clearing out old cookies) helps avoid the random session drops. I have some other guesses about the root cause, but they're more involved. :|
Dan Kehn

max

#22: Post by max »

Just stating the obvious, but after the first changes the other day, found myself being logged out again... but then realized I can't recall checking the remember me checkbox either :idea:

RockyIII
Supporter ♡

#23: Post by RockyIII »

I'm having to log in frequently, more than once a day. I use Microsoft Edge and always check the box to be remembered.

User avatar
HB
Admin

#24: Post by HB »

Try clicking the forget me link and then login without "Remember me". You should stay logged in for about an hour of inactivity before the session times out. That said, it could be browser-specific and I don't test with Edge.
Dan Kehn

Nunas
Supporter ♡

#25: Post by Nunas »

I'm suddenly getting this message from time to time, but only on H-B
An error occurred during a connection to www.home-barista.com:80. SSL received a record that exceeded the maximum permissible length.Error code: SSL_ERROR_RX_RECORD_TOO_LONG
Is this a related problem?

Edit: In fact, when I posted this I got the message. I then back-paged the browser and see that it actually posted.

User avatar
HB
Admin

#26: Post by HB »

Sorry about that, I was changing the server configuration and it looks like you may have caught it mid-change. Try clearing your browser cache and clicking the forget me link. I'll double-check on my end, too.
Dan Kehn

User avatar
HB
Admin

#27: Post by HB »

It's not an elegant workaround, but since the "remember me" option appears to be the source of the problem, I've disabled it for now and increased the session time to 48 hours. That means if you visit every day or so, you won't have to log in again.
Dan Kehn

RockyIII
Supporter ♡

#28: Post by RockyIII »

I made a correction in my cookie manager a few days ago, and the login here has been working fine ever since.

User avatar
HB
Admin

#29: Post by HB »

What is a "cookie manager" and how did you correct it? I honestly don't recall doing anything around March 26th that started this recent conversation. I've applied a few possible fixes, not really knowing what the cause is. Sometimes it's just a browser change that breaks websites like HB. :|
Dan Kehn

User avatar
JohnB.
Supporter ♡

#30: Post by JohnB. »

HB wrote:? I honestly don't recall doing anything around March 26th that started this recent conversation.
March 25 The H-B home page pretty much disappeared around noon for me & wasn't back to normal until the next morning which is when the login issue started. When I went to the home page on the 25th 95% of the page was blank with only a garbled list of current topics & a small H-B.com above it showing. No issues with my other forum/websites that day.
LMWDP 267