Daily login required again... - Page 2

Offer your ideas on how to improve the site or report problems.
User avatar
HB
Admin

#11: Post by HB »

It could be, Firefox recently made other changes that caught me offguard (specifically DNS over HTTPS for privacy reasons). I've noticed the occasional logouts, but nothing consistent and it varies from browser-to-browser. I have some ideas about possible causes, but it's really just guessing. :?
Dan Kehn

cpreston

#12: Post by cpreston »

I'm seeing it on current iPhone.

User avatar
CarefreeBuzzBuzz
Supporter

#13: Post by CarefreeBuzzBuzz »

Chrome, Safari, iOS here.
CarefreeBuzzBuzz
___
Artisan Quick Start Guide
http://bit.ly/ArtisanQuickStart

User avatar
HB
Admin

#14: Post by HB »

I'll look into it again this weekend. In the meantime, a sort-of workaround is having the browser remember your password. :|
Dan Kehn

User avatar
another_jim
Team HB

#15: Post by another_jim »

Yep, daily logins on chrome as well.
Jim Schulman

User avatar
Jake_G
Team HB

#16: Post by Jake_G »

Glad it's not just me...

Nunas
Supporter ♡

#17: Post by Nunas »

I'll look into it again this weekend.
Great, but don't sweat the small stuff. The site still works, albeit with the need for a couple of extra keystrokes on the front end. I for one am really happy you do what you do. Great forum; also a great bunch of contributors. I've hosted blogs, fora, and email lists on my server before. Nearly all of them eventually ended up in flame wars and misuse.

Nate42

#18: Post by Nate42 »

Think whatever you did yesterday did more harm than good. Yesterday I was forced to log back in, it insisted my password was wrong (it wasn't) and then ultimately locked me out of my account. Today I was able to reset my password and log back in, but it has made me log back in 5 times in the span of as many minutes.

User avatar
spressomon

#19: Post by spressomon »

Weird, as today is better for me and all things reset login requirement (OSX Mojave + Safari 13.0.05).
No Espresso = Depresso

User avatar
HB
Admin

#20: Post by HB »

I tried resetting the session tables; that means any existing "remember me" keys were discarded. If you're seeing login problems, please click this link and post the result. Otherwise I cannot investigate. Here's mine:
Browser is Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:74.0) Gecko/20100101 Firefox/74.0

Mobile: false
Tablet: false
iPad using Safari: false
Capability: A
I haven't seen any logout problems today with this browser.

Background for the technically inclined: The "remember me" logins are shown here. If you're seeing logouts, it might help to clear this table with mark all / delete marked. I've also noticed that the session cookie isn't always set right way (you can tell if there's a "sid=nnnnn" on the end of the browser URL); clicking on the index page seems to fix it (again, you can tell because "sid" will no longer be in the URL and you're still logged in).

Even more background for the technically inclined: The remember me key is stored as cookie "hbforums330_k"; if there's no active session in cookie "hbforums330_sid" and the remember me cookie is present, the visitor is automatically logged in again. The user id is stored as another cookie, "hbforums330_u". The remember me key and user id must match against the value in the database, otherwise they're ignored.
Dan Kehn