Proud new owner of a 1997 Elektra Microcasa a Leva! - Page 2

A haven dedicated to manual espresso machine aficionados.
User avatar
algue

#11: Post by algue »

I think it could be mainly a spring issue.
I found my old MCaL absolutely unsatisfactory with its original spring.
Now I'm quite happy but I have a double spring configuration.
However I must say that often I still prefer La Pavoni shots. I find in them more body.
alberto

nismo270r (original poster)

#12: Post by nismo270r (original poster) »

Hi all,

I've been super busy this past couple of weeks, but I was able to finally get the MCaL up and running. Using the chopstick trick, I checked on the roller and it moved freely, but I went ahead and removed it and put some fresh lube on it. I haven't pulled the group to re-lube though, as it has been silky smooth. I picked up some potassium bicarbonate and distilled water to give it a go. Super easy to mix up, but I did have a question. The 10% solution I made (100ml distilled water / 10g KHCO₃) I basically put 3.68ml into the remaining 3.68L of distilled water and the rest of the 10% solution is in a mason jar. Within a day or so, there were a couple of large, clear crystals that formed in the water that won't seem to dissolve regardless of how much I mix the solution. Is this normal? Should I crush the crystals up to get them to mix back into the solution? Am I completely over-thinking the water situation? :P

As far as the shots I've pulled so far, honestly it's left a lot to be desired, but I completely blame that on my inexperience with the machine. I'm sure it doesn't help I'm using a Baratza Vario that the sliders seem to be drifting on either, but it's what I have to work with right now. So far, the best tasting shot I've pulled has been with a 7.4g dose in the single basket, a very light leveling tamp (just the weight of a 49mm brass tamper base + Reg aluminum handle), 10 sec preinfusion, shot took about 35 sec.

I've tried the double basket and using a second pull, but I think I need to do some more homework on it before I get into that more. Every pull with the double basket/single pull has been in the right time range (~30 sec) but has been under extracted and sour. I'm guessing not enough water volume in a single pull to properly extract the 14-15g dose I tried. I may need to dial that back to around 12g and try again. I've had varying success with the second pull, with it generally flowing much quicker after that second pull. Checking afterwards, I'd say the puck cracked about 1/3 of the time, but even on the ones it didn't crack on, they still flowed really fast after the second pull. As I said before, I need to do some more homework on this and trying to figure out what grinder to get. So far I keep going back and forth between an E37S and the HG-One.
Chris
LMWDP #509