La Pavoni Millennium - Pressure Relief Valve or Pressurestat Problem

A haven dedicated to manual espresso machine aficionados.
SeekingGodShots2
Posts: 31
Joined: May 11th, 2016

Postby SeekingGodShots2 » Dec 07, 2017, 12:21 am

My LP Millennium just started to vent steam from the pressure relief valve. I have an add-on gauge and the steam vents at approximately 1.3BAR. The green light turns off as steam continues to vent to about 1.0BAR and the boiler/green light reactivates - cycling pretty much in quick order (this seems to indicate that the pstat is properly functioning).

In the past, I could hear the valve shut (pop) at around .4 or .5 BAR and the boiler shutting off at between 1.0-1.2BAR.

Is this a safety valve failure or the pStat (original)?

Finally, is there a ball bearing involved in the safety valve and spring assembly?

Thanks in advance for your feedback.
LMWDP #548

User avatar
drgary
Team HB
Posts: 9879
Joined: February 7th, 2010

Postby drgary » Dec 07, 2017, 4:23 am

Christopher Cara (whose father was the first importer of home espresso machines to the U.S.) told me when this happened with my Millennium EP to tap the end of the pressure relief valve and it would settle down. It just needs to re-seat. I use the bottom of my tamper to do that from time to time. BTW your pressure seems to be set high. I like to run mine so it shuts off at about 1.0 bar.
Gary
LMWDP#308

What I WOULD do for a good cup of coffee!

SeekingGodShots2
Posts: 31
Joined: May 11th, 2016

Postby SeekingGodShots2 » Dec 07, 2017, 11:21 pm

Thanks drgary. Coincidentally, my EPM was purchased at Chris Cara's shop in SF many years ago when it went exclusively to espresso machines. (His father, Thomas imported some of the most beautiful hand stamped copper pans ever produced.) As to a sticky pressure relief valve, tapping the valve cap has worked in the past, but not under present circumstances. I'm turning towards making an adjustment to the pressurestat after I overhaul the grouphead. Thanks again.
LMWDP #548

SeekingGodShots2
Posts: 31
Joined: May 11th, 2016

Postby SeekingGodShots2 » Dec 11, 2017, 3:10 am

Follow-up:
Problem resolved. It was the spring that holds the pressure stat in place. The existing spring measured 7mmx18mm when the specified dimension is 7mmx26mm. Elongated the spring to 26mm and reinstalled. No more steam venting. Cannot explain how/why the spring compressed to 18mm.
LMWDP #548

 
Sponsored by klatchroasting.com
www.klatchroasting.com: USBC champion, voted 2009 'best micro-roaster'