Recent Posts - Page 59

by Prodigy, August 1st, 2020, 2:06 pm in Coffees
Replies: 182 Views: 7657

Comments on Favorite Espressos 2020

Haha, I've been slowly moving through bag C trying to get to my unopened bag of caffe lusso GMC. It doesn't taste like my last bag did, and I havent changed any settings. The pulls havent had that rich, even distribution i was getting on my last bag. Maybe I need to coarsen the grind a little. So much fun...
by PIXIllate, August 1st, 2020, 2:05 pm in Repairs, Restorations & Mods
Replies: 14 Views: 421

Profitec Pro 600 - No Pressure/Water from Group

It happened again, and moving the flow control knob fixed it again. Enough is enough. Took the Flow Control mushroom head off and here's what I found: {image} Not exactly sure exactly what that little bit is. It appeared to be rubber when I tried pulling it apart. There is no obvious place within this chamber that it could have...
by another_jim, August 1st, 2020, 1:54 pm in Lever Espresso Machines
Replies: 15 Views: 619

Are there any generic/universal characteristics of a spring lever extraction?

This is an almost universal observation for lever shots. The other is the "fault tolerance" of levers, as mentioned by David. The way a lever works allows for finer grinds and makes channeling less likely. This creates a far smoother taste, but discourages the coarse grind/overstuffed basket shots that produce lots of crema, body, and bitterness.
by Diggidy, August 1st, 2020, 1:53 pm in Repairs, Restorations & Mods
Replies: 3 Views: 137

Breville Dual Boiler - Brew boiler overheating to 225 degrees

{image} Update: I took the top off the Ol' beast and found some water inside. I turned my machine on and let it heat up. Attached a picture of what I found. The two red circled objects are on the steam boiler. The left most one leaks constantly once at temperature - a slow leak. The right most one does...
by Marcelnl, August 1st, 2020, 1:53 pm in Home Roasting
Replies: 73 Views: 1575

1st effort roasting on Huky 500T... advice?

as long as you connect the lead from the correct physically located probe to the connection that ends up labeled correctly in Artisan you should be OK. In the end it's all the same standard TC (assuming the Huky is stock).