Profitec Pro 500 brew pressure builds *really* slowly [video]

Need help with equipment usage or want to share your latest discovery?
KoryWMajor
Posts: 4
Joined: Aug 30, 2017, 3:09 pm

Postby KoryWMajor » Sep 05, 2017, 6:56 pm

Just got this machine today. Video below with a blind basket. Any idea what's going on? I feel like pressure should build a lot quicker.

When brewing a shot, I only get up to about 3 bars or so.

Any ideas?


User avatar
tohenk2
Posts: 250
Joined: Jun 15, 2015, 8:43 am

Postby tohenk2 » Sep 07, 2017, 6:54 am

If it is new: contact the reseller.
If it is not new/under warranty: maybe replace some pressure valves? Maybe the Ulka EX5 vibration pump is not quite ok? (It happens. Descaling sometimes helps as well, but it can also cause some problems if bits of debris get loose.).

KoryWMajor
Posts: 4
Joined: Aug 30, 2017, 3:09 pm

Postby KoryWMajor » Sep 07, 2017, 9:05 am

Thanks for the reply.

It's a new machine. On it's way back for an exchange.

N6GQ
Posts: 86
Joined: May 11, 2015, 10:22 pm

Postby N6GQ » Sep 09, 2017, 1:20 pm

Yup, something's wrong. I have the same machine and the pressure comes up right away on the blind basket, within 2-3 seconds I'd say...good luck with the replacement.

KoryWMajor
Posts: 4
Joined: Aug 30, 2017, 3:09 pm

Postby KoryWMajor » Sep 13, 2017, 11:03 pm

The new Pro 500 showed up yesterday.

Works like a charm. Spent all day yesterday and today brewing shots and dialing it in! Having a great time.

Thanks to the folks at IDC for a quick resolution to my problem!

Image

 
Sponsored by baratza.com
www.baratza.com: skilled in the art of grinding