How do you lubricate a squeaky E61 lever mechanism?

Need help with equipment usage or want to share your latest discovery?
Nickel

#1: Post by Nickel »

If the lever on an E61 machine becomes squeaky, and the oil from the coffee does not cure this problem, how does one go about lubricating the cam?

Nick

User avatar
Compass Coffee
Sponsor

#2: Post by Compass Coffee »

Nickel wrote:If the lever on an E61 machine becomes squeaky, and the oil from the coffee does not cure this problem, how does one go about lubricating the cam?
Nick
Some people have talked of using a food grade lubricant like found here at Chris' Coffee. I've never used it myself. My Bric's lever became exceeding smooth and totally squeak free after descaling, which included backflush descaling. Still gets a bit of squeak back after detergent backflushes but goes away after a few shots.
Mike McGinness, Head Bean (Owner/Roast Master)
http://www.CompassCoffeeRoasting.com

Nickel

#3: Post by Nickel »

I meant how do you physically lubricate the lever.

User avatar
cannonfodder
Team HB

#4: Post by cannonfodder »

A squeaky lever is relatively common after backflushing the machine. If that is the case, a few shots will silence it. I also found that after a year of use my machine was squeaking more. After a descale the squeak went away.

I have over two years of use on my E61 and have never needed to remove the lever for lubrication.
Dave Stephens

laservet

#5: Post by laservet »

Nickel wrote:I meant how do you physically lubricate the lever.
Take it apart, starting with the screw on the end to get the handle off, then the next fitting, until you can pull the lever out. It has an eccentric cam on the end that depresses two little pegs inside the group, one above and one below. The little pegs are what need the lube. Use food grade lube, I got mine from WLL but there are other sources, and then reassemble. Works like a charm. A small amount of lube will do, keep in mind that whatever you use will wind up in your shots. I used WD-40 the first time but it gave my shots an off taste for a while. :-P Second time I really gooped it up with the food grade lube and I could see an oil slick on my shots for a week or so (but no off taste).

User avatar
xtophr

#6: Post by xtophr »

You can get a small plastic "tin" of food grade lube that has the consistency of petroleum jelly at home brewing stores. It's called "Keg Lube". That's what I'd use.

http://www.williamsbrewing.com/KEG_LUBE_P99.cfm

KHB

#7: Post by KHB »

I have noticed that the squeaking on my machine came from the interaction between the brewing lever and the pump switch (metal to metal). It also makes the lever difficult to move up and down. Just clean the back of the lever that touches the switch and everything works nice

User avatar
RegulatorJohnson

#8: Post by RegulatorJohnson »

i have a vetrano that is about 2 months old.

it has an annoying squeak when i lift or lower the lever. it needs lubrication. my steam valves also needed to be lubed to the same squeaky un lubed feel. chris has provided me with instructions on the valves. however, being the week end i would like to hook up my lever today or tomorrow. i have the time now and don't want to listen to it grind and squeak for another week.

thanks for your help.

jon
jon stovall
--
coffeetoolsapp.com

User avatar
HB
Admin

#9: Post by HB »

Jon, I merged your question with an existing one on the same subject. If you have time, would you post a couple pictures of the procedure for the next guy/gal? Thanks...

PS: Use a foodsafe high-temperature lubricant, e.g., Dow Corning 111 Valve Lubricant & Sealant.
Dan Kehn

BrianG

#10: Post by BrianG »

KHB wrote:I have noticed that the squeaking on my machine came from the interaction between the brewing lever and the pump switch (metal to metal). It also makes the lever difficult to move up and down. Just clean the back of the lever that touches the switch and everything works nice
Same thing on my Vetrano... the squeaking was coming from the friction of the lever against the little plastic cap on the pump switch. I was convinced I was going to have to use the food safe lube stuff inside the assembly, but a tiny drop of oil on the metal that contacts the pump switch completely solved the problem.